Guidelines – Bugs, glitches, crashes

Landing Page Forums Report Bugs, Glitches, Errors, Crashes Guidelines – Bugs, glitches, crashes

This topic contains 45 replies, has 12 voices, and was last updated by  felix043 5 months, 3 weeks ago.

  • Author
    Posts
  • #997

    David
    Keymaster

    If you encounter a technical error and want to report it, please share the following information to make it easy as possible for us to fix!

    Bug Report Guidelines:
    – Device Model
    – Description
    – Steps to reproduce (try your best to describe how to make it happen again)

    • This topic was modified 10 months, 4 weeks ago by  David.
    • This topic was modified 10 months, 3 weeks ago by  David.
  • #1020

    BB
    Participant

    – Device Model
    Samsung Galaxy Note 3 running Lolipop Verizon
    – Description
    Device hanging at “Registering Device for Push notifications” for several hours after logging in.
    – Steps to reproduce
    None. I never got past the splash screen πŸ™

    I have tried restarting the app several times. The problem persists. I will try to reinstall next.

    • #1021

      BB
      Participant

      In response to my earlier post, I reinstalled and the program seems to be working fine. It’d downloading the patch now. I think I may have lost Wifi during the initial loading process.

      • #1022

        David
        Keymaster

        I see! Thanks for the report anyways!

        • #1028

          BB
          Participant

          Nope. I’ve reinstalled twice. After I get through patching on my Note 3 it goes back to β€œRegistering Device for Push notifications”

          All I’ve seen of this game so far is a pretty splash screen and a cool rotating thing.

          • #1029

            David
            Keymaster

            @bb I appreciate the complements for our splash screen coolness factor.

            Unfortunately, we aren’t sure why it’s not working. One of our developers has a Note 3 and it has been working fine, so it’s not hardware related.

            Is your phone’s memory full? Perhaps the client was not able to patch completely, causing the loading to hang. The total apk size is about ~200mb after patching.

            • #1030

              BB
              Participant

              The phone tells me I have 1 GB left on internal storage. I have more on the SD.

            • #1031

              David
              Keymaster

              @bb We’ve got no other leads at the moment then. Sorry πŸ™

              In next week’s patch, we’ll try a fix to bypass that “Push Notifications” stage. We’re building on theory right now since there’s not much other data.

              OR you can private message us on our Facebook page, and we can send you a private hotfix .apk to test with.

  • #1023

    RPGIsLove
    Participant

    – Samsung Galaxy S5.
    – Login fail, potential bug.

    – Download the game and install the update like normal.
    – Game asks for the screen to be tapped.
    – It then begins to load Google Play profile.
    – Upon attempting to load the profile, it closes the green Google window.
    – A few seconds later it fails to login.

    Additional information – My friend also got into the alpha, and we’ve begun testing the cause of this issue. For now, we believe it’s because I have multiple accounts linked to my phone, but the Google profile I used to sign up for the game is not the main profile on my phone. The game seems to automatically choose the first profile, hence the login error, it’s trying to load the wrong profile. We will continue to test what the cause is, either proving us right or wrong, and give an update as soon as we figure it out.

  • #1024

    David
    Keymaster

    You are probably right with the account mismatch. Copy the link you used, and press it while logged into your GooglePlay account (log out of the others if you have multi-account enabled). When you press the link, it registers that account for the closed alpha.

    This issue won’t be a problem when open beta arrives, since it won’t be account specific locked.

  • #1032

    fearnlj01
    Participant

    – LG Nexus 5 (Lollipop 6.0.1)

    – Loss of sound
    – So far, it looks like this is caused by a notification coming through on the phone which stops the game from playing any audio from the point of the notification onwards. This repeatedly occurs when the low battery notification, incoming emails (gmail) and with twitch notifications.

    – Back button links to the wrong thing
    – After going into the factory to the upgrade menu using the back button to return to the factory links directly to the map rather than the factory unlike the construct and recycle menus which seem to work correctly

    – Loading screen spinnner hangs
    – In the loading screens the loading spinner hangs for a second or two, namely when just before completing loading or moving onto the next ‘loading progress message’.

    On a slightly related note which doesn’t really warrant it’s own seperate post, it feels like the cloud cover when opening the app after loading is still loading as the full cloud cover stays fullscreen for a questionably long time, enough to wonder if the app has crashed

    • #1043

      David
      Keymaster

      @fearnlj01 Thanks for the reports!

      – Loss of sound
      This is a weird situation that we’ll have to test more since it’s caused by device interactions.

      – Back button links to the wrong thing
      Fixed now!

      – Loading screen spinnner hangs
      This is just a case where the device is loading everything to screen, so the performance dips for just a second during that.

      – it feels like the cloud cover when opening the app after loading is still loading
      This is the same case as above where the screen lags a bit behind (varies by device).

  • #1034

    RPGIsLove
    Participant

    My issue has been fixed. It was simply the Google profile switch that fixed it. Thank you, David.

  • #1035

    Wark
    Participant

    – Asus Nexus 7 (2013), Android 6.0.1
    – Tank duplication bug. One of the tanks becomes a clone of another tank you have. Example:
    Here’s what my team normally looks like
    Here’s an example of the bug. Notice that my Hellcat in the second slot has turned into a second Cromwell.
    I’ve encountered the bug twice so far. I think that both times it happened after I had checked one of the tank’s stats/equipment, but I have not found a way to deliberately reproduce it. Everything returns to normal after restarting the game.

  • #1036

    BlueSharp
    Participant

    Device Model
    Asus Zenfone 2

    -Description
    a tank in my squad turned into a duplicate of an other tank in the squad and i ended up with 2 identical tanks which i could take in battle

    this switching has happened to me in 2 different ways, first time it got reset after i restarted game and the 2nd time it was permanent, the first time i was checking tank details when this occurred, and i ended up having my T-34/85 replaced with a panzer II after i restarted the app it was fine again. the second time is much more serious as i had my Crusader replaced by a BT-7 and i could take both them in battle, and they stayed this way even after i restarted the app

    -Steps to reproduce
    the 1st time, i tapped on the panzer II tank details,and then tapped on the T-34/85 and it showed me panzer II, when i closed the window panzer II had replaced the T-34/85,could not reproduce it yet, as for the second one i did not even noticed when it happened until i saw that i had 2 BT-7 in my squad on the field ,i later figured out it was supposed to be a crusader

    a few pictures here

    Bugs 2 jun 2016

  • #1044

    David
    Keymaster

    @bluesharp @wark You both are having the same issue, but it seems difficult to reproduce on our own devices. We’re working on figuring it out! Thanks for reporting.

    • #1054

      BlueSharp
      Participant

      i’ve got this bug recorded in case u want to see a clip of it, also while i’m here, 2 more bugs that are not very urgent. the enemy tanks that don’t move and shoot explosives on “a mysterious portal -I” map (lvl 12) miss tanks that are moving but once they stay still they get hit, and 2nd one, if u get called on your phone during a fight the sound cuts off and dose not reset until u get out of the battle.(got both events recorded)
      P.S. fast question regarding bugs, would u like us to spam you with every small bug we find or just report the bigger and more urgent ones?

      • #1055

        David
        Keymaster

        @bluesharp For the tank duplication bug, we sort of found out where it happened and did replicate it a few times. But it’s still a bit inconsistent so we need to hunt down the code to find out what’s wrong.

        -The missing shots thing is actually a result of slower rotation speed for some tanks. Destroyers and Artillery have slow rotation, so they tend to miss moving units.

        -The sound cutting out thing is weird. It happens consistently, but not sure why. We are looking into it!

        Every bug that shows up (even the smaller ones) we would like to know about! There’s tons of stuff we can’t catch on our own and that’s where everyone else can help out.

  • #1045

    Hubbles
    Participant

    Device Model
    Samsung Galaxy S6

    Description
    Progress I made earlier today got wiped, even though I was on a connection the entire time

    Steps to reproduce
    Happened after I had to force close the app, as it wasn’t responding anymore, maybe that was the entire reason it got wiped?

    EDIT: Another thing that I forgot to mention entirely:

    The app becomes unresponsive when I…tab (?) out of it to another app or simply press the home button on my device. It takes at least a good 30 seconds before it responds again, when I tab back into it.

    • This reply was modified 10 months, 3 weeks ago by  Hubbles.
    • #1047

      David
      Keymaster

      @hubbles Thanks for the report. We’ve had a couple problems with save data syncing not working. I think the crash after unresponsiveness was the cause of losing that play session. We need to have the save points distributed more liberally to avoid crash wiping.

      We’re also trying some things to work around network instability. (The likely cause of the tabbing in/out lag)

  • #1049

    BlueSharp
    Participant

    Device Model
    Asus Zenphone 2 android V5

    Description
    the app dose not save progress somethings and it is possible to reset your construction if u don’t like the result(including resources)

    I’ve noticed that sometimes the app doesn’t save your progress and if u close and reset the app u are being sent back to a previous state ,i am not exactly sure what causes it but i suspect its related to the amount of time spent in the current game session, However this can be used to reset constructions, which is prone to abuse.

    Steps to do it
    just attempt construction regularly and use the red currency to instantly finish it, check the result and if u don’t like it just close the game without exiting the result screen,when u log back it the materials will be there including the red currency, i have tried it 3 times, 1st time it worked and it got reset, 2nd time it did NOT work and i got the tank and 3rd time i kept the tank πŸ˜› because it was good

    • #1050

      David
      Keymaster

      @bluesharp I think the save issue is the same that caused a session wipe on crash like Hubble’s problem. We’re going to do a complete overhaul of the save system to add in more backup copies. This change may take awhile!

  • #1060

    Wark
    Participant

    – Asus Nexus 7 (2013), Android 6.0.1
    – Can’t equip items in certain situations.
    If you try to equip, for instance, a second engine on a tank, you’re going to get a “cannot equip two items of the same type” message, which, I assume, is working as intended. However, if after that you go back to your squad overview and try to equip this item on another tank, which does not have an engine (or even does not have any equipment at all), you’re still going to get the “cannot equip two items…” message. The bug seems to disappear if you return to the main map and enter the army tab again.

    – Related. While I was trying to reproduce the glitch above, I have somehow managed to equip two barrels on my Hellcat. I will try to mess around and reproduce that, but, unfortunately, at the moment I have no idea why the game suddenly allowed me to do that.

    • #1062

      David
      Keymaster

      Hmm it seems the item system is the cause for a lot of our bugs (tank duplication as well). We’re going to disable that and probably rewrite the whole thing since it is old code.

  • #1061

    BlueSharp
    Participant

    i’ve got 3 more minor bugs

    1st the overworld map node of Deadly Mountain Pass shows the icon for Xanthippe but the battle screen shows Blight(side note i love the enemy designs up to the point where i want them in my squad and hoping to be able to capture them in the future)

    2nd, the resource node just above that shows a metal mine but yealds Oil.

    and the 3rd one , when i won a battle the result screen showed a different commander that the one i had ,i had Natalia the Russian one but it was showing me i think the American one, could not replicate it

  • #1077

    BlueSharp
    Participant

    Model Asus Zenphone 2 Android 5

    new patch new bugs,big and small

    For one the save system dont really work all the time. its less “exploity” but it can still be done
    i crafted a sherman Easy 8(4 star) and tried to enter battle only for the game to crush and when i got back in the tank was not picked up from the construction so i ended up with a 1 Star something.(that’s my third 4 star tank i lost)

    also mid battle if u exit app right before losing it still dosent save so u can reenter the battle without cost

    the mailbox dosent work anymore,i cant open it, i managed to trigger the dark shade effect on it(when u tap it) but it dosent open(ive noticed someone already posted this in a other topic, would u like us to post bugs in this 1 topic or make one for each different bug?)

    in battle your tank reserve always shows 6 for some reason even if u have less or more than than

    in battle your cost currency (the one u use to summon tanks) is stuck at 15 on the display but the system works properly

    and a minor one from the last patch and still present i forgot to mention about ,the app dose not prevent sleep, if u idle too much it will close your screen

    • #1089

      David
      Keymaster

      Are these bugs still present after reinstalling? There was a weird in-between stage with the patching and updating so a couple things were broken.

      • #1092

        BlueSharp
        Participant

        i am pretty sure these are from the new patch,i remember updating about 5-6 hours after the patch was ready(8PM EST), and i updated using the download link for the app i got from the invitation email,
        and yes all of these bugs are still present even when i am posting this reply. however the save system seems to be random, exiting a battle is a guaranteed to not save(i do it every time i am about to fail :P) and for the construction exploit its odd because i was able to do it about 4-5 times before it stoped working, then i did 4 more constructs and i couldn’t exploit any of them, so the bug is still present but some improvements have been made

        • #1093

          David
          Keymaster
          the mailbox dosent work anymore,i cant open it, i managed to trigger the dark shade effect on it(when u tap it) but it dosent open(ive noticed someone already posted this in a other topic, would u like us to post bugs in this 1 topic or make one for each different bug?)
          
          in battle your tank reserve always shows 6 for some reason even if u have less or more than than
          
          in battle your cost currency (the one u use to summon tanks) is stuck at 15 on the display but the system works properly

          These bugs should all have been fixed in the most recent update. If these are still happening, then you likely have an outdated apk and need to reinstall.

          The other bugs with save exploits is part of a larger overarching issue. Still finding a workaround for that one without having too many save sessions. It will take some restructuring to get that perfect.

          • #1106

            BlueSharp
            Participant

            okay I’ve had time to reinstall it and sure enough it it was actually an other sneaky patch( suggestion add a patch version somewhere on the loading screen) and most of the bugs mentioned have been fixed(including the selected items in the selling section) however i have found 2 more bugs and 1 comeback bug with possible clues,

            the 1st is with the mailbox, now that a lot of missions have been enabled i had a lot of rewards to get but every time i collected one the other ones would disappear from the list, making me have to restart the app for them to reappear, so basically if i had 5 rewards i would have to reset the app 5 times to get them all.

            2nd is probably a false alarm but i will post it anyway, i have noticed that sometimes when taking aim with the artillery target jitters around and sometimes goes way off. i’ve noticed this while making a gameplay video and I’ve used Bluestakcs because audio recording, so i had the mouse visible on the screen, when using my phone this was not very obvious because my finger was in the way. the bug is visible at 9:54 https://www.youtube.com/watch?v=cYnXxkEaAg0 the mouse is standing still but the target is moving around
            (also currently the video is unlisted, asking for permission to make it public)

            and the comeback bug. the tank duplication bug is back and its more aggressive then ever i’ve had a Churchill 1 duplicate itself 2 times and a B1 once (and one of the tanks i lost was a Stug, that’s the 4th 4 star tank lost) now its a bit odd how it did this, the Churchill was always in my 10th slot, but it duped to the 1st slot and then to the 2nd one(possible clue maybe)

            Edit: forgot to post picture

            View post on imgur.com

            • This reply was modified 10 months, 3 weeks ago by  BlueSharp.
            • #1108

              David
              Keymaster

              Thanks for the updates @bluesharp! There will be a new patch tonight for the saving issues and some other minor things. For the other stuff you listed, it’s in our queue with tank duplication at the top.

              About the video – you can share it if you want, but don’t make it public yet. There’s so many bugs in this build lol. Too embarassing >//<

            • #1110

              BlueSharp
              Participant

              so be it,no public… yet. but still there isn’t much to be embarrassed about,you guys made a game and it works most of the time, works better than mine, and i have to present it as my bachelor degree, there are not a whole lot of people who can say that.

              P.S. while messing around with bluestacks found an other really minor bug. in the mission list the progress bar dose not disappear where it should

              View post on imgur.com

            • #1111

              David
              Keymaster

              Good luck in your own pursuits of game development! I’m a recent graduate, so I was in your shoes just a couple months ago.

              About the progress bar, when the bar disappears is actually based on frame rate. If you scroll really fast, the bar goes further past that boundary. But maybe I can look at it later πŸ˜€

  • #1097

    ReBootYourMind
    Participant

    – Device Model: Samsung Galaxy S3 LTE
    – Description: http://i.imgur.com/208voqn.jpg The fonts are too small to read in the map and the icons look like they are out of focus.
    – Steps to reproduce: Look at the map

    • #1098

      David
      Keymaster

      Can you try reinstalling the apk and seeing if that helps? I think there was a patching issue from last Saturday.

      Otherwise, you can wait until Tuesday night and we will try another patch fix.

  • #1561

    Divortex
    Participant

    Device model
    HP7 voicetab kernel version 3.4.67
    Description
    Can’t get pass the “loading user data”,( I’m waiting for 2 hour with perfect wifi and still can’t get through)
    Steps to reproduce
    Just open the game and keep stuck in that loading screen

    • #1562

      Nymbryxion
      Moderator

      Do you happen to have Google Play Games disabled? We found that that is sometimes the cause when players are starting the game and can’t log in.

  • #1564

    Divortex
    Participant

    I have Google play game always on, and I can finally play the game after reinstalling the game 5 times

  • #2043

    Mr.Trololo
    Participant

    Device: Huawei P08 Lite
    Description: The game gets stuck at Calculating files to download. Doesn’t download anything, and I left the app open for hours. On my PC the game works great, but on mobile not. Any idea what’s wrong?

    • #2044

      David
      Keymaster

      There’s a problem with a lot of devices from the Asian manufacturers that have trouble loading. So it’s probably the issue that we’re working on fixing right now.

  • #2349

    felix043
    Participant

    Device: Samsung Galaxy Note 3 SM-N9005
    Description: Every time I try to start the game, I tried to start the game, I get the error: “Error while calculating patchfile differences”. I’va already reinstalled the game, deleted all data and restarted my device many times.
    I dont know how to reproduce because I’m getting this error without doing something myself.

    • #2350

      David
      Keymaster

      We’re trying to figure out a fix for this one. What device are you using?

      • #2351

        felix043
        Participant

        Samsung Galaxy Note 3 SM-N9005

        • #2352

          BlueSharp
          Participant

          i get this at almost every update, if uninstall the game and reinstall it the update will work again.

          • #2354

            felix043
            Participant

            I have updated the game and reinstalled it but it still doesnt work

  • #2353

    felix043
    Participant

    I have updated the game and reinstalled it but it still doesnt work.

You must be logged in to reply to this topic.